(Last Updated: May 4, 2020)

Get Vera files throwing errors



  • Hello,
    Had a RPI laying around and saw the cheap razberry board so picked one up last week. Am trying to set up ALTUI and connect to my Vera Plus. Of the 80 or so devices it pulled in from my Vera, only about 14 look like they are functional. When I run the GetVeraFiles from the VeraBridge actions menu, I see a bunch of 503 errors in the log. If I open the URL that it is erroring on in the browser, it usually returns a valid image or page.

    Is there a way to attach logs to messages or is it acceptable to just paste in the entire thing as text? Let me know what info you need to see to point me in the right direction.

    Thanks,
    Roger



  • OK, for a start...

    • which version of openLuup?
    • which version of Vera firmware?
    • what security settings do you have set on Vera? (ie. is running Lua code allowed?)

    I guess that a zipped attachment will work, although maybe just quoting the text...

    like
    this



  • OpenLuup: v19.12.27
    Vera: 1.7.4970 (7.31)
    Secure the controller: OFF
    Enable Potentially unsafe lua code: ON
    Enable UPnP: OFF
    Since writing the earlier post. I blew away cmh-ludl on my RPI and reinstalled openLuup from scratch. Now I am not able to connect to the vera. It has a red title bar in devices. IP is correct under attributes.
    These lines in log file look weird to me: The URL doesn't contain the IP of the vera even though it sees it a few lines earlier.
    openLuup.io.server:: HTTP connection from 192.168.0.174 tcp{client}: 0x1ed7788

    openLuup.client:: WGET error status: -1, request: http:///port_3480/data_request?id=action&serviceId=urn:micasaverde-com:serviceId:HomeAutomationGateway1&action=RunLua&Code=%0a%20%20local%20lfs%20%3d%20require%20%22lfs%22%0a%20%20local%20f%20%3d%20io%2eopen%20%28%22%2fwww%2fdirectory%2etxt%22%2c%20%27w%27%29%0a%20%20for%20fname%20in%20lfs%2edir%20%28%22%2fetc%2fcmh%2dludl%2f%22%29%20do%0a%20%20%20%20if%20fname%3amatch%20%22%2e%2a%22%20and%20%28fname%3amatch%20%22lzo%24%22%20or%20fname%3a%20match%20%22png%24%22%20or%20fname%3a%20match%20%22svg%24%22%29%20then%0a%20%20%20%20%20%20f%3awrite%20%28fname%29%0a%20%20%20%20%20%20f%3awrite%20%27%5cn%27%0a%20%20%20%20end%0a%20%20f%3awrite%20%27%5cn%27%0a%20%20end%0a%20%20f%3aclose%20%28%29%0a%0a%20%20
    2020-05-02 14:35:33.020
    Let me know what part of logs you want to see.



  • Update:
    I uninstalled the VeraBridge and reinstalled it and it seems to be updating the devices now. Scenes have populated, though not all the light switches are functioning.



  • You’re using a rather old version of openLuup. Suggest you update to the latest. Just click on the update button next to openLuup on the Plugins page.



  • Actually, you want the development branch, not the master branch



  • Type in development in the box next to update before you hit the update button in more > plugins



  • This post is deleted!


  • Well, that completely horked it.
    Now I am getting this in out.log
    lua5.1: ./openLuup/loader.lua:476: Implementation XML root element name is not 'implementation'
    stack traceback:
    [C]: in function 'error'
    ./openLuup/loader.lua:476: in function 'parse_impl_xml'
    ./openLuup/loader.lua:553: in function 'read_impl'
    ./openLuup/loader.lua:735: in function 'assemble_device'
    ./openLuup/chdev.lua:141: in function 'create'
    ./openLuup/userdata.lua:551: in function 'load'
    openLuup/init.lua:244: in main chunk
    [C]: ?

    Assume I can go to the dev branch on gethub and pull down the latest files?



  • That didn't work either. WIll wait for the experts to reply.



  • Got it to work again. Now I am on 20.5.1 of openLuup.



  • Just wondering if there are lessons for me to learn from this?

    ...is there something specifically you did wrong, and then right, to fix things?



  • @akbooer The master branch apparently has those implementation files still enabled.



  • I should clarify my last statement of "getting it to work". What I was referring to was getting past the error message and getting the ALTUI interface to load.
    Here is the sequence of events from yesterday.

    1. Deleted the cmh-ludl directory that I had originally installed in the /home/pi path.
      Was having issues getting openLuup to run on startup based on the samples in the openLuup users guide. (more of a windows guy than linux).
    2. Created a cmh-ludl in /etc, so that the install point matched the scripts in the doc.
    3. Ran sudo lua5.1 openLuup_install.lua which installed the v19.12.27
    4. Based on comments in thread added "development" to Update dialog box and ran update script. That completely broke everything. openLuup would not load.
    5. Tried to copy openLuup files from github to my RPI. That didn't work either.
    6. Reran sudo lua5.1 openLuup_install.lua and it installed the 20.5.1 version (at least that is what it says on the plugins page).

    So the current state is that ALTUI runs. I can control a few switches through my Vera from ALTUI. The majority of my devices are displaying the generic z-wave icon and have no control buttons.
    In devices, VeraBridge has a red title bar even though I can control it.

    When I try to run the GetVeraScenes action I get this in the LuaUPnP log:
    "2020-05-03 09:36:17.169 luup_log:5: GetVeraScenes action called
    2020-05-03 09:36:17.374 openLuup.server:: request completed (2581 bytes, 1 chunks, 16755 ms) tcp{client}: 0x29334d8
    2020-05-03 09:36:19.706 openLuup.server:: GET /data_request?id=lu_status2&output_format=json&DataVersion=463507015&Timeout=60&MinimumDelay=1500&_=1588522721664 HTTP/1.1 tcp{client}: 0x29334d8
    2020-05-03 09:36:30.267 openLuup.io.server:: HTTP:3480 connection closed EXPIRED tcp{client}: 0x237b8d8
    2020-05-03 09:36:30.469 openLuup.io.server:: HTTP:3480 connection closed EXPIRED tcp{client}: 0x21da810
    2020-05-03 09:36:30.470 openLuup.io.server:: HTTP:3480 connection closed EXPIRED tcp{client}: 0x2a04e58
    2020-05-03 09:36:30.470 openLuup.io.server:: HTTP:3480 connection closed EXPIRED tcp{client}: 0x24e02a0
    "
    When I run GetVeraFiles I get a bunch of these:
    "2020-05-03 09:39:19.118 openLuup.client:: WGET error status: 503, request: http://192.168.0.143/port_3480/D_ReactorSensor_UI7.json
    2020-05-03 09:39:19.118 luup_log:5: ERROR: D_ReactorSensor_UI7.json
    2020-05-03 09:39:19.121 openLuup.client:: WGET error status: 503, request: http://192.168.0.143/port_3480/D_DelayLightTimer.xml
    2020-05-03 09:39:19.122 luup_log:5: ERROR: D_DelayLightTimer.xml
    2020-05-03 09:39:19.129 openLuup.client:: WGET error status: 503, request: http://192.168.0.143/port_3480/D_VenstarColorTouchThermostat1_F.json
    2020-05-03 09:39:19.129 luup_log:5: ERROR: D_VenstarColorTouchThermostat1_F.json
    2020-05-03 09:39:19.133 openLuup.client:: WGET error status: 503, request: http://192.168.0.143/port_3480/I_DelayLight.xml
    2020-05-03 09:39:19.133 luup_log:5: ERROR: I_DelayLight.xml"

    I can, however, paste this, http://192.168.0.143/port_3480/I_DelayLight.xml, in the browser on my RPI and it returns the xml data.

    Thanks for your assistance.



  • Ok, that's lots to go on.

    I've just done a completely fresh install on a RPI of the development system (crrently v20.5.3, actually, but no material difference from what you're trying.) Donwloaded all files successfully from a Vera Edge, running 7.30.

    I think that, at this stage, I'd like a copy of the startup log and the main log after a restart.

    In addition, the listing provided by the openLuup console Startup page would be of use:

    http://openLuupIP:3480/openLuup?page=startup

    I'm worried by the red banner on the VeraBridge device.



  • Here is the startup page:
    Plugin Startup Jobs CPU usage (in startup order)

    date / time device priority status hh:mm:ss.sss job # info notes

    1 2020-05-03 13:17:38.558 2 1 Done 0.004 1 plugin: openLuup sync in 21.9 s
    2 2020-05-03 13:17:38.559 3 3 Done 0.000 2 plugin: Alternate UI
    3 2020-05-03 13:17:41.731 5 5 Abort 2.793 4 plugin: VeraBridge ./openLuup/loader.lua:476: Implementation XML root element name is not 'implementation'
    4 2020-05-03 13:17:41.847 6 5 Done 0.008 5 plugin: Z-Way OK
    5 2020-05-03 13:17:41.848 4 Done 0.001 3 plugin: Alternate App Store OK

    Link for log files sent via chat.



  • OK, straight-forward error. How did you create the VeraBridge plugin? It doesn't have a correct implementation file. What do its device attributes look like?



  • I I created the VeraBridge by going into the app - Plugins and clicking the update button.
    altid
    category_num 1
    cpu(s) 2.793128
    device_file D_VeraBridge.xml
    device_json D_VeraBridge.json
    device_type VeraBridge
    disabled 0
    id 5
    id_parent 0
    impl_file I_VeraBridge.xml
    invisible 0
    ip 192.168.0.143
    local_udn uuid:d764c8cc-e932-55c4-478d-7aa05d83f3ea
    mac
    manufacturer akbooer
    model
    name VeraBridge
    plugin
    room 0
    status -1
    subcategory_num 0
    time_created 05/02/2020 04:29:14 PM
    altuiid 0-5
    favorite false
    dirty false



  • There are several inconsistencies here.

    • The startup page shows a failure to read the implementation file, yet the details in the startup log show that the VeraBridge plugin has started correctly.
    • The VeraBridge version as reported at the end of the startup log (19.12.12) is not consistent with the version number of the openLuup system.

    If you look in the cmh-ludl folder, and in its files folder, do you find any VeraBridge files? There should be none. The only findable VeraBridge file should be the L_VeraBridge.lua one in the openLuup folder (20.4.30). If there are any others, delete them.

    I believe I know what went wrong, but the above should get you going OK.



  • There is only one Verabridge file on the cmh-ludl folder or any of the sub's located in the openLuup folder. File header is:
    BOUT = {
    NAME = "VeraBridge",
    VERSION = "2019.12.12",
    DESCRIPTION = "VeraBridge plugin for openLuup",
    AUTHOR = "@akbooer",
    COPYRIGHT = "(c) 2013-2019 AKBooer",
    DOCUMENTATION = "https://github.com/akbooer/openLuup/tree/master/Documentation",
    DEBUG = false,
    LICENSE = [[
    Copyright 2013-2019 AK Booer


Log in to reply