(Last Updated: October 3, 2020)

Time out of sync



  • Hi akbooer,

    Small issue, i have Reactor running in openLuup, I have a time setting of 7.00, in Reactor it fires at 7.00, But in the browser it show as 8.00. Looking at the time openLuup console the time is showing 1 hour slower than the browser time. Both browser and openLuup are running on same machine.
    I have hunted for setting to adjust time but can not see one. Can you point me in right direction.



  • There is no explicit time setting – it simply picks it up from the system. However, the one hour offset hints at the problem, perhaps, and is maybe a Daylight Savings Time issue.

    Although your system might be showing the correct time, does it, in fact, have the correct locale setting? It's possible to have an apparently correct time, but an incorrect underlying Unix epoch value if this is not set right.

    The locale shell command should tell us something.



  • ok local returns

    LANG=C.UTF-8
    LANGUAGE=
    LC_CTYPE="C.UTF-8"
    LC_NUMERIC="C.UTF-8"
    LC_TIME="C.UTF-8"
    LC_COLLATE="C.UTF-8"
    LC_MONETARY="C.UTF-8"
    LC_MESSAGES="C.UTF-8"
    LC_PAPER="C.UTF-8"
    LC_NAME="C.UTF-8"
    LC_ADDRESS="C.UTF-8"
    LC_TELEPHONE="C.UTF-8"
    LC_MEASUREMENT="C.UTF-8"
    LC_IDENTIFICATION="C.UTF-8"
    LC_ALL=
    

    date returns Sat Oct 3 16:40:58 UTC 2020



  • ok i think i fixed it
    just copy the content of
    /usr/share/zoneinfo/myregion/mycity
    inside
    /etc/localtime



  • On further advice i just crated a synbolic link to thr zoneinfo file for my city.


Log in to reply