(Last Updated: April 30, 2020)

vera - motion sensor stays tripped



  • I know how to uptrip but it is so annoying that lots of motion sensor keep tripped...

    ("urn:micasaverde-com:serviceId:SecuritySensor1", "Tripped", 0, 986)

    Any tips or suggestion to avoid this sensor behaviour?



  • I assume you mean that Vera is not seeing the "untrip" event from the motion detector, a sadly common problem in recent firmwares. I 've solved it by adding the "AutoUntrip' variable to the device with a \ time-out delay to untrip the sensor. 60 seconds is a good value, but you can choose any number you want.



  • Can you give me more information on how to achieve that? Very interesting!



  • I practically completely eliminated this problem after ditching the vera.
    It is as @HSD99 says due to misses of the untrip frame coming from the device and this frame often lost because the vera is having fun with itself... either in a got CAN, in a tardy wait mode, reloading luup or that portion of the network doing a wakeup nnu or a wakeup poll. There are all kinds of mechanisms as you can see for it to fail and the larger the network is with battery operated devices and secure class devices, the more likely this happens. Hopefully this is not a ghost trip which then means that there is no untrip frame coming behind it... this is a vera data corruption problem either in the user-data.json file or in the vera RAM.
    The auto untrip is one way to resolve it but it is really a workaround, patch... not one that I would recommend. The fundamental solution is to get the untrip frame from the sensor and to do this we need to reduce chattiness of the zwave network.

    The autountrip is below:

    local deviceID = **the device you want to set**
    local time = **the time after which it untrips in seconds**
    luup.variable_set("urn:micasaverde-com:serviceId:SecuritySensor1", "AutoUntrip", time, deviceID)
    


  • Yes, but since zway is not natively integratable in home assistant I am stuck with Vera... for zwave...



  • Short of going with z-way, you can go to the native openzwave on Home Assistant... Vera offers no advantage over OZW anymore. It has actually fallen quite a bit behind it.

    And you don't even need new hardware. You can just "nuke" the vera and use it as your zwave and zigbee radio for home assistant using the home assistant components for them. In that case, you won't even have to rebuild your network. OZW will just take over the vera zwave network and make it this much better. You will have to rebuild Zigbee though.



  • I do have a vera edge, only zwave, no zigbee. And I would not know where to start before even "daring"...



  • Makes no difference that it is an edge

    https://smarthome.community/topic/5/nuke-vera-script

    The zigbee part just won't work



  • There is zero risk in doing this. Just run a vera backup. Worst case, you just restore. I just provided a script to make it easier.

    It's actually much less risky than starting a network from scratch since you don't risk not being able to include or configure devices and you can go back easily. Starting from scratch is a "no return" path.



  • Sorry, but for me this is rocket science. I do not fully understand it as a whole and therefor dont know where to start. For example, killing the processes except the ones listed... will that survive a reboot? The thing is, if I do something wrong I don't have enough skills to revert or go forward...



  • A bit surprising given the fact that you run home assistant which is much more involved and complicated to setup and maintain than this:

    To answer your questions:
    Does it survive reboot? yes... the last step of the process is to reboot.
    How to undo? Factory reset and restore backup.

    All it does is prevent all the mios programs from loading at boot up and adds ser2net which sends the serial signal over your network. You then get socat to pick up that port and reflect it on Home assistant as if it was a local serial port. You can thereafter use the openzwave component (zwave2mqtt, QTopenzwave, zwave, they are all based on openzwave) of your choice on Home Assistant. No different from your vera component today, just much better integrated.



  • Ok, I have a spare vera... I am willing to try...

    So what should I do step by step?
    Step 1. This vera has no zwave devices currenlty
    Step 2. Nuke vera with you script?
    Step 3. Follow home assistant link above?
    Step 4. Have a zwave device connected to vera and it should show in hass?

    What I dont get yet, I run hass core. A vm on esxi. I cant ssh to "linux" other than the basic linux on which hass runs but it seems I cannot really "do" something there. So how could I do:
    On Home Assistant - first ssh connection

    install socat with “apt-get install socat” or whatever package manager your distribution has...

    And what I do not understand fully is how vera could then be an OZW1.6 one?



  • The Home Assistant link is a step by step. That one does not fully survive reboot.
    My script run on the vera only does the vera part. It just goes a little further by making it resistant to reboot and disabling really everything from vera/mios. You still need to access your home assistant machine and install/setup socat per the home assistant forum. Maybe I should add that in my github read me to make it easier.

    You have two possible scenario here.

    1. If you have no device on the vera, you will need to use Home Assistant to include them... yeah no more vera inclusions.
    2. If it is your vera you are migrating, all your devices will show in home assistant under the zwave menu if you use the zwave component, or the other zwave interfaces (zwave2mqtt or QTopenzwave) if you use one of the other 2 components. You can continue expanding your network from there. Again, no more vera software. You are just reusing the hardware.

    Do your research and decide which one to choose. Home assistant offers many components. The newest one is QTopenzwave. The native zwave is the oldest but most integrated one.

    I too run “Hass Core”. It’s really a misleading name because it is the most complete and flexible version of Hass. Not just the core. The others are just customized, limited versions to run as a container or a self contained OS. If you run Hass Core, you probably have a full linux OS in the VM.

    As to your last question. Maybe this is where you are the most confused. What you call vera is primarily a piece of software. I described it in my post about the vera different layers of connections but I admit, does not really address your confusion. It is really just a program running on OpenWRT which is a Linux distro. No different than say Home Assistant running on ubuntu, z-way running on windows or any other OS.
    The UI you see is an open source webserver program called lighttpd reading from the /www folder.
    The Luup engine is a binary compiled from C code called LuaUPnP located in /usr/bin and it relies on a number of libraries and connects to the zwave radio through a program called zwaveserial which I talk about in another thread here. The zwave radio is connected to the mini computer through a serial port which is what the zwaveserial program calls. What you see on windows as a COM port is shown under linux as in the /dev/ folder as a TTYXXXX port.

    Now the hardware. The various Vera Edge/VeraPlus/Vera Secure are devices sourced from SerComm, a company in Taiwan notorious for being an OEM for other companies producing mostly wireless routers and IPcams. The vera is hardware wise a wireless router with additional radios with its original operating system on top of which mios slapped a couple of programs. You prevent the mios programs from starting, and you end up with basically a device like a rPI with a zwave radio running OpenWRT linux. From here on you can think of it as just that. A tiny computer with your zwave radio onboard and forget that it is a vera.

    Now zwave radio chips have the particularity to have onboard memory and this memory stores all the data from your network. It is made of the HomeID, which identifies your network, the list of nodes, your device list, and their routing. It does not contain the command class information for these nodes.
    So... If you kill the vera programs, you end up with a tiny linux computer with a zwave radio and all your zwave network info in it. You can just send this serial port through ethernet to your home assistant VM and have home assistant manage it. This the purpose of folks in the link above.



  • Rafale, very clear and very understandable. But again option and options... as I am not an expert in this I will probably hit the wall after the first corner. 🙄


Log in to reply