• 0 Votes
    3 Posts
    16 Views

    Have you seen this post?

    https://smarthome.community/topic/1525/forum-sysops/4?_=1713755285910

    Or is this in addition to the above?

  • 0 Votes
    7 Posts
    120 Views

    To close this thread out, it wasn't a Reactor issue. My Rpi 3B+ was simply overheating and throttling processes. Moved to an Odroid N2+ with a heatsync running Ubuntu and everything is running smoothly!

  • openLuup: Shelly Bridge plugin

    Pinned Plugins
    143
    0 Votes
    143 Posts
    7k Views

    Ouch, sorry!

    Away from my development system for a couple of days, but will dig into it when back.

    Have to find out why I didn’t run into this myself when testing (I do, actually, test things!)

  • 0 Votes
    3 Posts
    200 Views

    @toggledbits said in HomeAsssistant Weather changed.... Global expression no longer functioning:

    Chalk it up to Home Assistant's legacy of breaking changes. The whole matter of service calls being able to return data came about in 2023.7 but didn't work until 2023.12 for the websocket API, and didn't apply to anything anyone seemed to care about until now. So current Reactor doesn't store that response anywhere, and in fact doesn't know to ask for it, and the service you're calling requires it, so you're probably getting an error in the log that you haven't spotted (always look at the logs when things don't work as expected!).

    Until I get a fix for this into HassController, the only remedy right now is to downgrade your Hass back to 2024.3 or earlier.

    P.S. This is why I say in the documentation and have HassController complain bitterly when you're running a Hass version that isn't yet supported/verified. I assume you got a warning about that, too.

    74fbb817-75f3-47ce-b948-fb3ef1afefb1-image.png

    Thanks Patrick, that's pretty much what I had figured. It wouldn't be the first time that HAAS has changed something 6 months ago and broke my setup.

    I did see the notice yes, however, I think there was another notice I got from HAAS that told me if I didn't upgrade that something else would stop functioning. Always a balancing act unfortunatley.

    Let me know when you come out with a version of HaasController that addresses this, and I'll gladly test it out for you.

  • zigbee2mqtt and openLuup

    Plugins
    7
    0 Votes
    7 Posts
    204 Views

    Yes my rookie mistake. Mixed up the function's variables being returned versus the function itself being returned. Was on the right track as "configure (dno) has fixed the issue. Thanks.

  • openLuup: Version Log

    Pinned Locked openLuup
    34
    3 Votes
    34 Posts
    2k Views

    Development Branch: 2024 Release 4.8

    Eclipse Edition

    further refactoring of Shelly Gen2+ devices fix missing variables for Shelly H&T support for Shelly Gen1 RGBW2 controller
  • 0 Votes
    18 Posts
    1k Views

    @toggledbits yeah, I just got new hardware and am considering moving to the containerized version. But that's going to take some time as it's tech I've not played with before and my day job + new puppy haven't left much dev hours these months. 🙂

    MSR is now very integral to the operation of this house so I need to tread carefully when poking the proverbial bear.

  • iCOMEN boiler switch

    Unsolved General Discussion
    1
    0 Votes
    1 Posts
    93 Views
    No one has replied
  • MiOS is Winning the X10 Wars

    Vera
    5
    1 Votes
    5 Posts
    341 Views

    "Hi, I'm Troy McClure, famous from such posts as 'How to Send Data to Google Sheets from Rule Machine', and 'Creating Zero-CSS Animated SVG Backgrounds for Hubitat Dashboard Tiles Using Hidden iFrames', and other esoteric topics nobody wants to read."
    But srsly, I did expect more response when I recently released my very first full-fledged HE Device Driver which pits you against an AI bot in the game of TicTacToe on a gameboard created out of 12 button Tiles. 😉
    TicBot Game

    @toggledbits sure won't miss my MSR antics, but I do! What's the point of beta testing if you cannot first crush the everlivin' life out of something while probing its deepest, darkest recesses.

    Indeed, first thing I inquired about after joining HE Forum a few years back was "Can this thing tie in with X10?" (A: Yes and, more pointedly, no.)

    I would love to visit here more often, but must confess you guys are so awesome you've left me nothing to BREAK!

  • 0 Votes
    3 Posts
    148 Views

    Rene,

    You don't need all that, this should be sufficient:

    select_capabilities: power_sensor: attributes: value: true

    or the equivalent, using an array of attribute names (my favorite):

    select_capabilities: power_sensor: attributes: [ 'value' ]

    or using the other YAML array syntax:

    select_capabilities: power_sensor: attributes: - value

    You can also use a negative to suppress an attribute:

    select_capabilities: power_sensor: attributes: [ '-units' ]

    Also, can I ask that you go back and fix the formatting of the code sections of your posts, for the benefit of future readers looking at your question and example solution?

  • 0 Votes
    5 Posts
    176 Views

    Ah, if I only known what to search for or had a really good memory I would have found ev_charger announced here but not listed in Standard Capabilities 🙂

    My charger seems to ignore out of range values as well so ev_charger was the missing piece in my quest, thank you @therealdb.

  • 5 Votes
    98 Posts
    12k Views
    MQTTController build 24085 Support for Shelly H&T Gen3 (use shelly_handt3 template and set topic). This is a battery-powered WiFi device, so its attributes will not be fully populated until the first wake-up.
  • ZWaveJS and MQTT

    openLuup
    14
    0 Votes
    14 Posts
    470 Views

    @toggledbits Thanks for that. Zensys had it as their proprietary stuff ie under their control for ages and it's still a constellation of confusion. For example - how hard should it be to copy a set up from one USB stick to another? They really shot themselves in the foot a long time ago. Meanwhile Zigbee seems to have flourished?

  • 0 Votes
    5 Posts
    325 Views

    Just finding this but defo interested.

  • 0 Votes
    2 Posts
    138 Views

    I have also encountered this problem on a recurring basis. I tried many different approaches - reboot RPI, restart MSR, reboot hubs - to correct the issue, usually without success. Earlier is week I decided to try something different. I "repaired" the "Hub Information Driver" using the Hubitat Package Manager. As so I the "repair" was complete on the hub, the problem disappeared.

  • 0 Votes
    2 Posts
    142 Views

    You would likely need to use the x-hass.call-service action on the lock entity and your service ID would be zwave_js.set_lock_usercode. In the data portion you'd have to fill out the code_slot and code. Note that this will not work if your lock isn't securely included with your HASS controller.

  • 2 Votes
    2 Posts
    160 Views

    Nice work! That’s a problem which has been waiting to be solved for a very long time,

  • 0 Votes
    4 Posts
    165 Views

    @apocalypsehobby please read the posting guidelines, a pinned post in this category. There are some specific requests for log files and snippets.

    Also rgbcolor.set takes a hex color code or decimal equivalent. It's probably not what you want to be using. set_rgb is more common.

  • 1 Votes
    23 Posts
    1k Views

    Oh I use the VPN for email 🙂

    C

  • full devices reset

    Zway Bridge
    77
    0 Votes
    77 Posts
    2k Views

    You only get that lucky once in every four years!

Recent Topics