(Last Updated: August 20, 2020)

Migration from VeraPlus to Aeotec Gen5



  • I have 50ish devices in connected to Home Assistant via. VeraPlus hub. I recently picked up an Aeotec Gen5 USB stick which I have successfully integrated into Home Assistant using OpenZWave.

    Can I add the Aeotec Stick as a Secondary Controller to Vera, turn off vera (making Aeotec primary) and then run natively that way on HA?

    I know the entity ID's in HA will change, but a lot easier to fix vs. unpair/repair all the devices from Vera.

    Will this work?



  • A couple of inputs on this:

    1. I know the aeotec stick looks attractive with its on board battery but... battery eventually dies and using the stick as a mobile inclusion device using your main controiller stick is not the best idea as it is supposed to be static. (look at the zwave SUC/SIS concept). I would really avoid this stick and recommend the generic stick like the homeseer one or the ones sold directly by silabs which offers much better compatibility with firmware and sdk upgrades.
    2. To answer you question, you could add that stick as a secondary but it would make a mess on your network since it requires a controller shift to make a controller primary. It isn't as easy as flipping a switch or a bit. The process involves an new inclusion of not included controller into the network and a shift of all the properties into that new controller which then turns the previous primary into a secondary. You can do this multiple times, shifting the primary role back and forth between the controllers to finally get the stick you want to have the node 1 position but... there is a better way which I described in my migration to z-way process. You can restore from the vera's zwave binary backup onto the usb stick which you would have plugged into the vera....


  • Hi Rafale,

    I am not planning on using the stick for that purpose, but to potentially remove VERA from the equation completely.

    I would be leveraging the aeotec stick plugged in full-time with my Home Assistant installation (which is NOT running on a RPi, etc.) so it would be a static deployment which would be build on the OZW 1.6 stack (in Home Assistant).

    Does your migration to Z-way process (restoring the binary backup onto the stick) still work in that scenario? I would also need the existing vera NW security key which I input for the OZW startup config.



  • The migration method is designed exactly for this very use case.
    My recommendation was to avoid the aeotec stick. It uses a proprietary firmware which you will not benefit from for your use case and will only be suffering from the lack of support over time as they do not offer much firmware updates.



  • Hi, I think most people use the aeotec g5 stick with ozw 1.4 and latest ozw 1.6 (addon) according to the home assistant forum... I am not saying it is good, but why so many people if it were bad?

    I also use it with ozw 1.6 addon. It is also recommended to not use the stick for inclusion but use the integration or vnc for inclusion.



  • I have one too. It is stuck with zwave SDK 4.5. It will never support S2 inclusion for example and it is missing support for some newer devices. It is missing a lot of bug fixes silab has released over the past few years. My generic sticks and the uzb are running 6.82.01...



  • Thanks Rafael for the information as you are much more knowledgeable on Z-Wave than I am. Which USB Z-Wave stick would you recommend then?



  • A few suggestions since it appears that you are in the US:

    This is the most generic reference design stick. It is actually also the exact same stick homeseer and many other companies resell under their label.

    The is the zwave.me uzb which is widely used on Home assistant and opens the door to using z-way as well.



  • @rafale77 hmz, according to them gen5 will support S2

    And here



  • Maybe one of these days when others have supported it for years. It's not the point. This is just a symptom, it's a proprietary firmware to accomodate the battery which is not very useful. You pay more and get a less useful stick. I have had it for years and you have to wait for aeotec to release a firmware which may or may not happen. Why bother? They have not released an update for all the years I have had mine when silabs is releasing improvements and bug fixes every couple of months. If you were not happy with vera's firmware release rate, you will be sorely disappointed with aeotec's Z-stick. And no it doesn't work. The current firmware doesn't support S2, it is much too old. The documentation is wrong. I tried. It mentions you need a controller which supports it which none does except for homeseer and z-way which don't support this stick. It was a very popular stick back at the beginning of openzwave when it was a very limited controller but I think openzwave has outgrown the firmware on this stick now.

    Edit: I see a firmware update for another product called the z-stick S2. None for the Gen5 which I know for fact cannot support S2.



  • @rafale77 said in Migration from VeraPlus to Aeotec Gen5:

    A few suggestions since it appears that you are in the US:

    This is the most generic reference design stick. It is actually also the exact same stick homeseer and many other companies resell under their label.

    The is the zwave.me uzb which is widely used on Home assistant and opens the door to using z-way as well.

    In regards to the Z-wave.me stick... does that also accept the SL SDK FW upgrades directly or are you going dealing with their FW as well.



  • You have to deal with waiting for their firmware so it is the downside. They have been pretty responsive to my request for an update though and have historically provided pretty regular updates, albeit not as frequently as Silabs.



  • I receive the Z-Wave.Me stick from Amazon. I installed into Rpi4b and wrote the z-way SW onto a spare SD card. Z-Way doesn't show the USB stick as being recognized.

    I was able to get the following information from the board:

    Device ready in:3.01858210564 seconds
              FULL INFO
    Openning port                            ..............................                            OK
    
    
              SERIAL INFO
    		 VERSION:  05 1B  VENDOR:  01 15
    
              ZME_CAPABILITIES
    		     UID:  25 95 B6 A0 D7 34 FA 69 67 EB BA 75 3F 4B C6 8B
    		  VENDOR:  00 00   NODES: FF
    		   FLAGS:  05 00 00 00 00 00 00 00 00 00 00 00 00
    
              FIRMWARE CRC
    		    BOOT:  BB BB      FW:  35 7A
              MISC
    		    FREQ:  US
    
              				 NVR Content
              --------------------------------------------------------------------------------------------
              Prog/erase lock :  FF FF FF FF FF FF FF FF, Read back lock: FF
              Rev 01, Cal FF, TXCal  16 12, SAW  FF FF FF FF, Pin FF, CRC  B3 B5
              NMV: CS 15, TYPE 02, SIZE  01 00, PSIZE  01 00 (EEPROM M25PE20)
              USB: VID  FF FF, PID  FF FF, UUID  FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
              --------------------------------------------------------------------------------------------
              FACTORY ID: WEEK 255, YEAR 255, CHIP  FF FF, SER  FF FF, WS 255, HWREV: FF FF, CRC8 FF
    

    Does this look right?



  • Hard to help on this. The vendor code seems to be correct. It looks like it has a pretty old firmware. 05-1B would be 05.11.
    What have you tried on z-way?



  • Went into expert UI - controller info - and nothing is being reported / shown. Update firmware option offered no choices. Acting like not recognized



  • Have you tried disabling and reenabling the zwave app with the correct serial address from the smarthome UI? That's how you should be activating the dongle.



  • I finally figured out how to get SmartHome to see the Dongle, and upgraded it to from 5.27 > 5.36 > 5.39. It didn't show any boot loader updated needed.

    Weirdly though SmartHome doesn't show the SDK version # under controller info.




Log in to reply