(Last Updated: May 15, 2020)

Cannot add ZOOZ power strip in Zway



  • Hello,
    Recently picked up a 5 socket zooz powerstrip to use to test with. Tried adding to my Razberry setup and while I can get it to be seen, the only thing showing in the Z-Wave app are the master switch, and two power monitors (KWh and W). None of the individual sockets are showing up. Anyone have any experience with power strips?



  • I think this device is very similar to the one @iRobot was discussing. Have you completed interview and can you show what command class it displays after NIF/forced interview?



  • Not sure what you are asking for.



  • @RogerO

    This is likely the problem... How did you include it on the razberry?
    The inclusion of more complex devices must be done through the expert UI.
    You would go under Device/Status of the expert UI and then select the device in question after which you should see this:

    Screen Shot 2020-05-11 at 06.30.47.png

    where you can see the call for NIF button, the force interview button and the list of command classes I spoke of.
    I also suspect that this power strip support S2 security class so you may need to include it securely with S2.



  • I did it through the expertUI. It fails some of the Interviews:
    Failed ones are:
    SwitchBinary
    AssociationGroupInformation
    ZWavePlusInfo
    MultiChannel
    ManufactureSpecific
    PowerLevel
    FirmwareUpdates
    Association
    Version
    MultiChannelAssociation
    SecurityS2

    How do I remove it from Zwave? Don't see that option in the expert UI.



  • It is not uncommon to not get to 100%. Some devices have a command class registered on their list but actually don't have them implemented in their firmware. (it's the fault of the device manufacturer who may have forgotten to remove it from their node info)

    This does not appear to be your case. I suspect for you that the problem comes from the non secure inclusion which zooz may not support. Do you have one which succeeded called "security"?

    For exclusions, go under the "Network" menu and into the "control" screen. This is where you can include with or without security too.
    If your device supports non secure inclusion, you may want to look into its manual as well. I know I had an Aeotec plug which needed to follow different wakeup sequences depending on whether they were to be included securely or not.
    To use S2 inclusion, you will need an S2 key which should be somewhere in the device documentation or packaging.

    Edit: Have you tried going into the interview results and manually interview the command classes one by one? Sometimes this is required if the device has a lot of command classes and is not respond timely to how fast the "forced interview" process from z-way is.



  • Going from bad to worse. Now when I try to add it in the expert UI, it says "device fond" and then does nothing. I can include and exclude all day long but the device never shows up. Argh.



  • It doesn't show up on the device menu list? It will not show up in the control screen obviously. This would be rather odd. I have never see this behavior, neither myself nor on the zwave.me official forum.

    One other possibility is that it requires S2 and you would need to follow the S2 process from the smart home UI. Generally if it says device found and does nothing, it either means the device is already included in the list or that it is expecting something else (ie. key exchanges) to happen. Either way, the device should be displayed in the device list.


Log in to reply