(Last Updated: May 25, 2020)

z-way-server ubuntu install



  • After seeing some people struggling with their installations on ubuntu 64bit, I figured I would post an installation tutorial:

    First start by making sure you have all the dependencies loaded and packages up to date.

    sudo apt-get -y update && sudo apt-get upgrade
    sudo apt-get -qy install libxml2 libarchive-dev curl
    sudo apt-get -qy install sharutils tzdata gawk
    sudo apt-get -qy install libavahi-compat-libdnssd-dev
    sudo ln -s /usr/lib/x86_64-linux-gnu/libarchive.so.13 /usr/lib/x86_64-linux-gnu/libarchive.so.12
    

    Then download and install z-way-server (current latest version is 3.0.6) and install it in the /opt folder

    wget http://razberry.z-wave.me/z-way-server/z-way-server-Ubuntu-v3.0.6.tgz
    sudo tar -zxf z-way-server-Ubuntu-v3.0.6.tgz -C /opt/
    

    Then follow the auto start process here:
    https://smarthome.community/topic/108/auto-start-z-way-server

    For ubuntu 18 and later, there is currently an issue with z-way-server not supporting the newest libcurl4 causing apps download failures so the following additional steps are needed:

    Force downgrade to libcurl3 and save a copy of it and then upgrade back to libcurl4

    sudo apt-get -y install libcurl3
    sudo cp /usr/lib/x86_64-linux-gnu/libcurl.so.4 /usr/lib/x86_64-linux-gnu/libcurl3.so.4.5.0
    sudo apt-get -y install libcurl4 libcurl4-openssl-dev
    

    stop the z-way-server if it is already running:

    sudo systemctl stop z-way-server
    

    edit the systemd service file

    sudo nano /etc/systemd/system/z-way-server.service
    

    And add the following text at the end of the Environment line after adding a space to separate from the previous quote:

    'LD_PRELOAD=/usr/lib/x86_64-linux-gnu/libcurl3.4.5.0'
    

    Hit ctrl-o and ctrl-x to exit nano

    and now start the server again after updating systemd:

    sudo systemctl daemon-reload
    sudo systemctl start z-way-server
    

    I did all of this a while ago and had forgotten about it. Thanks to @sender, I remember now... 🙂

    PS:
    I don't frankly recommend using the rPi in spite of being the "default platform" as I find it a bit slower. That being said, Raspbian buster has the same problem as ubuntu 18+ but apparently the apt repo for raspbian doesn't have the older libcurl. zwave.me has provided a full raspbian buster image with the old libcurl library. My test rPi was upgraded from a raspbian stretch installation and does not appear to have this problem.



  • Well that seems reasonable

    C



  • @rafale77 Thanks for these instructions.
    The part I never got working properly was that libcurl4 issue.

    Now it's clear to me how to address this, I will most certainly try again.

    Thanks again for your work!



  • @rafale77 said in z-way-server ubuntu install:

    apparently the apt repo for raspbian doesn't have the older libcurl

    That should be pretty easy to fix as well, though

    C



  • Yes I think so too. Adding the older repo should not be hard.



  • @rafale77 said in z-way-server ubuntu install:

    Yes I think so too. Adding the older repo should not be hard.

    Certainly not normally.

    C



  • So, today my dead-new arrived ZMEEUZB1 usb dongle arrived. plugged it in the VM, USB-passed through it and can see "something" in zway again. But I cannot seem to have it "fully" seen. Do you think I need to do some more?
    E.g. Is do see:
    b6ea97cc-1098-4bd8-a3b0-307c03a45283-image.png

    3236410a-30e0-4688-8a1a-943e881d64f8-image.png

    08a4c799-840b-473f-979a-0929152c5fed-image.png

    8ddc1c02-3f4e-4703-853f-d46fadaaf5a4-image.png

    but I don't see:
    15521ccc-11b6-4fe5-b957-5f6b0b526d14-image.png

    Hm... now I m looking (after pressing Cal for NIF) and it says:
    02f10942-f1c9-4d71-a1ad-f709af67e137-image.png

    do you think I am "up and running" again?



  • Looks like you are up and running. Just call on NIF on the z-way controller. This status is just a single variable switch which was probably not toggled back. If it persist, I can give you a url to switch it off.



  • Well... I did only press that "Call for NIF" thind and since it is dead. rebooting and pulling usb stick do not help:

    4fede045-cf6b-4365-9a28-e28fc9e5b9cf-image.png

    it does something the button:
    1a4993bc-6116-4fd5-a9d1-52524ef5fae2-image.png



  • The fact that you get to that screen is already an indication that it is not dead. You can safely ignore that message.
    If it was dead, you would not be able to access the job queue and you wouldn't get any background noise level.
    Just start building your network.



  • well... I removed the device from vera (z-way) and everything in the server settings is the same (SIS etc) so I will have to add as secondary controller again...

    One thing I do not get... i why is EVERY screen about configure including firmware upgrade saying:
    fcc216f1-a72e-4888-ae71-971411588861-image.png



  • Ignore that too, this device can't be configured through zwave. It is a controller. If the device has not be interviewed to support the configuration command class or wakeup command, it will show this message. Most devices don't support this command class and only battery powered devices which are not FLiRS support wakeup.

    It seems like you had it perfectly working and you broke it by doing things you should not be doing.
    It's good for you to play around and to learn how zwave works. You were obviously bothered by things which were perfectly normal and have been breaking your configurations trying to fix things which were not broken.
    What you saw were not error messages or incomplete connections. They are just normal behavior based on the specific device and controller you have.



  • Ok definitely something is wrong here. I have added to vera as secondary controller, it is detected by vera. but not just like last time it shows no devices at all in z-way... just 1 in vera with device id 104 and in z-way with 104 as well...

    and... omg? z-way is now micasaverde and vera is zway:
    a076b99d-60bd-4622-be2a-eb05fbf0dc85-image.png

    2d71acfd-555a-46da-9027-31495e51b52e-image.png

    force interview does nothing...

    it seems to be included somehow:
    6673fc9f-ed1e-4739-b310-ff8cb0984b9b-image.png



  • @rafale77

    Qoute
    It seems like you had it perfectly working and you broke it by doing things you should not be doing.
    It's good for you to play around and to learn how zwave works. You were obviously bothered by things which were perfectly normal and have been breaking your configurations trying to fix things which were not broken.
    What you saw were not error messages or incomplete connections. They are just normal behavior based on the specific device and controller you have.
    Quote

    What do you exactly mean I had broken? I have just received a new ZMEEUZB1 stick today. I had to remove the device from Vera (previous stick) and to connect this new stick to my z-way server... there is nothing I did try to fix what was broken...?



  • You can also read the z-way manual.
    Looking at your screen shot, it looks like you went ahead and called a NIF on the controller because the firmware update tab showed that the service is not available.
    You are on a zwave screen. It means that the firmware update tab is a zwave OTA upgrade function. Since you selected the z-way controller chip, it will obviously not be supported. OTA means over the air. It is obvious to me because I have been digging around zwave for some time but I suppose you were trying to upgrade the controller. This is done in the controller menu the same way you did it before. After you called the NIF, you broke the controller information because a NIF is a zwave message sent by the controller into the network. So you basically ask Paul to go send a radio message to nobody (since you have no other devices) what's Paul's name. It doesn't make sense and that's why you got a failure.

    Now on adding vera, it doesn't look like you did it correctly either. You seem to have set vera in inclusion mode correctly but for z-way, you need to put it in learning mode under network/control/join network. If you set it to just send a nif to the vera, it will do just that and be added as a device without knowledge of what else is on the vera network. As for the node 1 showing mi-casa verde. It's perfectly normal too because this screen shows the info for the master controller. The vera is the master and will show up in z-way as node 1 but since the name of the node has not been updated (interview is not done), it still is named Z-way. You can do a refresh interview and this should be corrected in the case your z-way was included as a controller and not as any device. It seems you did all these before but have forgotten how. Play around and get more familiar...



  • Rafael, you are right... I don't know z-wave well enough. at least the low level details. I am just a user that wants a "stable" network without too much trouble. And yes to achieve that I realize I need to get familiar with the terminology and techniques.

    For that vera inclusion part. I did exactly what was on page 1 of https://smarthome.community/topic/63/adding-z-way-as-secondary-controller-to-vera-zwave-network/38 just like last time. That's pretty straightforward and I cannot imagine what could be wrong there... You write " You seem to have set vera in inclusion mode correctly but for z-way, you need to put it in learning mode under network/control/join network." and with that you mean below though?

    673e8774-b395-4690-9069-e286afcdb2c0-image.png



  • Yes, I meant include into network. after you do this, all your devices on the vera will show up in z-way. Vera does not support S2 so you don't need to worry about the first section.



  • Ok, I update the firmware of the stick a few times.

    Now trying to include in Vera... but got stuck after many minutes:
    0f2acfbb-7fb1-4a93-9805-746c581d450e-image.png

    8e33257f-06c3-45eb-91b9-b9e1c2dc21a1-image.png

    I do get the fact that when all is well this product should be awesome. But having spent so many times (and money) and took so many hurdles to get things going, this is where my journey ends and I would like to thank you all kindly for all help and effort. I really hope one day z-wave will see the light but I think this way, it will only get darker. Don't get me wrong, there is always a small group of enthusiasts to which I also wanted to belong but with SO MANY TROUBLES, User side (mine/me) or technology side this is too many steps too far for me.

    Thanks again and it was a very pleasant view to have my vera devices in z-way for a very little while (around 15 minutes) about 2 weeks ago.

    A BIG THANK YOU AGAIN!

    Update: just took A LOT of time?:
    fbd1436c-6d1e-4eb7-86ad-a79d552e285f-image.png

    afa8f396-0721-4d4f-971f-69e33b1297c7-image.png

    but still no devices... like last stick (2 weeks ago):
    f3951f54-1865-4dd5-99f8-17738f4baeb6-image.png



  • You got an error because you tried to exclude a device from z-way when the exclusion process needs to start from the master controller. You need to set the vera in exclusion mode and then go to z-way to "leave the network".
    The way you did it, the vera has not configured the z-way controller yet. It just included it. Because it is an unknown device, the vera buggy autoconfiguration will not work. You have to disable auto configuration on the vera to get rid of that error.
    All z-way does when you hit the leaving the network button, is to wakeup the z-way's zwave chip. It is expecting the master controller to be in exclude mode. If it isn't it will fail and this is by design.

    When adding a secondary z-wave controller, you have to think of it as just an additional device on the network. That's all it is. Everything you did using the vera remains the same. Nothing has changed. Configuring devices, including, excluding... all the same. You would be doing the same thing if you included another vera or any other controller or even any other device and needed to exclude it.

    Understanding how zwave works under the hood is not very complicated and essential but most of your problems are caused by vera's incomplete implementation of z-wave network control making things very obscure.
    If you had started from clean from z-way, you would have a much simpler system. If you want to run a dual controller, setup, you will need to learn how the z-wave topology and commands work at the most basic level. If you want a clean and simple z-wave system, you are better off getting rid of the vera and forget everything about it.



  • @rafale77 said in z-way-server ubuntu install:
    If you want a clean and simple z-wave system, you are better off getting rid of the vera and forget everything about it.

    I want! But there is a way between Vera <--> homeassitant and Z-way <--> homeassistant. Well 2 ways. 1 is migrating and 2, the most important one, there is nothing for z-way in home assistant, the MQTT plugin is buggy, installation is not straight forward etc...


Log in to reply