(Last Updated: May 14, 2020)

Internet access



  • It seems like zway really wants to use wifi for internet access. It doesn’t see my ethernet connection and thinks it has no internet but I can’t find anywhere to change it.
    TIA
    |-<:)



  • What's the error message you got ?



  • This definitely an operating system configuration problem with the pi. Z-way does not control this.



  • @rafale77 every other app works fine. This is a fresh buster install with no changes, this was the very first thing I did. I tested internet access which works just fine, I was able to get the Zway installation, so it has working internet. I can't see zway's apps to install.



  • @DesT "The request failed because server does not responding. Looks like you've slow or lost internet connection. Try to reconnect and refresh the page."



  • Ok this is not an internet access problem but likely a libcurl version issue.

    https://smarthome.community/topic/109/z-way-several-questions/8

    I am testing on my pi which was installed also on a fresh buster and had the same problem previously. I don't seem to be having it since I upgraded to 3.0.6. What version of the server are you running?



  • Started with 3.0.6. Curl is installed and working.



  • @rafale77 Tried to do the libcurl3 procedure, but it's not available on apt-get, these are the closest:

    libcurl3-gnutls/stable 7.64.0-4+deb10u1 armhf
    libcurl3-nss/stable 7.64.0-4+deb10u1 armhf
    

    This is so frustrating.



  • yeah z-way-server was not designed to work on buster or ubuntu 18. It does not support curl4. I have asked them to change this apparently since 2018 when I first ran into this problem. I don't seem to have it anymore though but my production unit is running on ubuntu 16.



  • Zwave.me specifically says, only supported on stretch and buster. I am so frustrated I'm giving it a timeout.
    |-<:(



  • I'm having issue with buster, that's why I'm using stretch for z-way!



  • I ask @PoltoS to make the 3.0.6 release available for buster!



  • Screen Shot 2020-05-13 at 10.21.07 AM.JPG



  • is the zwave on zway THAT much better then HomeAssistant?



  • Sorry guys I was having a blast trying to get @sender going with his installation over PMs. Turned out to be an attempt to run the 64bit ubuntu x86_64 version on a 32bit ubuntu VM. Anyway.
    So yeah the Buster support is actually a full customized OS image for you to install on an SD card. Not ideal but it has liburl3 installed. I am trying to figure out how I got mine to work as I think I actually had a stretch installation which I later upgraded to buster so I am currently not seeing this problem. I also have no problem on ubuntu 16 which natively runs libcurl3. If/When I find out how to get libcurl downgraded reliably on both ubuntu and raspbian, I will post it. It seems the both of you are fighting the same problem.



  • @prophead said in Internet access:

    is the zwave on zway THAT much better then HomeAssistant?

    Yes, at least at the moment. z-way is also not that much harder to install. It is just not as well documented.



  • @rafale77 I respectfully disagree. Having lived through the curl3/4 nightmare that is known but not documented and having incorrect installation instructions on their installation page. I am loath to trust my home automation to an outfit (one guy) with such low quality standards. My red lights are flashing.
    |-<:(



  • @prophead

    I understand your experience and the frustration especially for a paid product but if you put things in perspective and if you are also on the Hass forum, you may find a viral thread a few days old in which I also posted, reflecting how difficult it is to maintain a project such as this which has an identity issue swinging between wanting to be "firmware like" (fully embedded OS image whether for a full machine, a VM, or a container) and just a program you can install anywhere. Hass adds the complexity of adding a docker container option which complicates the whole thing more than it simplifies it. I struggled mightily to install and maintain Hass and used that experience when I installed z-way which I found very easy in comparison in spite of the lack of documentation.
    Remember also that the curl problem only affects a small portion of the program which you may or may not need. The z-way-server was built as a demonstrator GUI for the underlying library and API which is then used by various developers. As a result I never even interact with the standard GUI (smarthomeUI) of z-way-server and use exclusively the expertUI which is by far the most advanced zwave management tool anywhere. And even then I rarely need to toy with it since the system is very stable.

    Understand also that this demonstrator was initially meant to work on the rPi with Raspbian stretch. The official support for Raspbian buster only comes in the form of the OS image.

    It isn't a single dev, they actually have a team, @PoltoS just happens to be the (english speaking) face of it. The difficulty is the same as for Hass... there are a lot of issues related to dependencies upgrades breaking things which is why the Hass team wants to move towards a more controlled embedded image solution and stray away support of the "program on any OS" direction. I have had my share of grief with upgrading the OS or Hass on my Hass VM. Far more than with the z-way-server which has much fewer dependencies.

    This not an excuse for poor documentation and incomplete/incorrect installation instructions. Heck even their upgrade script did not work for me on buster but it isn't a reflection of the quality of the zwave library and API. It is only a "feature" of linux supporting all platforms and distros. I hate to say this but if you want to test the windows version, you will see that it is very easy to install and works just as well.



  • I agree with @rafale77 too, I never use the smarthomeUI, I mainly use the expert mode too and I use openLuup for everything. zway is mainly just the bridge to "talk" zwave.



  • Yep, I'm on the windows version because I have a mini PC around with windows as base os and then a Linux VM with Ubuntu and openluup. It worked well at first install. I'll eventually move it to a RPI, or not - we'll see.


Log in to reply