(Last Updated: May 21, 2020)

Help with Z-Way plugin



  • I hope this is the correct forum – apologies if not!

    I have a Raspberry Pi3 with a Razberry Z-Wave card installed. I have installed the Z-Way software and have successfully included a Fibaro Z-Wave switch on the Z-Wave network. I can toggle the switch on and off successfully from my laptop through port 8083 of the Raspberry Pi3.

    On the same Raspberry Pi3 I have installed openLuup on which I have installed the Z-Way plugin. I can access this through port 3480 on the Raspberry Pi3 from my laptop.

    Here is where I have come to a dead stop. How do I get access to the Fibaro Z-Wave switch from the openLuup application? I can find no documentation that tells me specifically how to do this.

    Any help would be greatly appreciated.

    _John.



  • I'm expecting the experts will chime in soon.
    But to get you started, I will try to help with what I know.

    You need to "link" the Z-Way plugin to your Z-Way "server". Because both of them run on the same RPi you only need to enter the credentials you use to login to your Z-Way. This should be the message you see on the plugin in openLuup.

    Entering the credentials can be done in the plugin under actions. Enter your username and password and click on the login button.

    Hope this helps.



  • @JMK

    Welcome!

    I think @iRobot said it all on the previous post. It sounds like you are almost there. You just need to set the bridge up to talk to the z-way-server on the pi.
    The only thing I would add is that you need to make sure of, is to enable the API on the z-way-server under the app/z-wave menu



  • @JMK said in Help with Z-Way plugin:

    I hope this is the correct forum

    Definitely the right place!



  • Is it best to have zway server on its own pi and run openluup on a second pi or both on the same pi? My lans fast and it seems like 2 pis will distribute load better. Will I have any issues running two different zwave networks in the same house as I make my slow transition? Can zway server work entirely locally with no internet? If I do start a zway only pi should I use their prepackaged os image or start from the Raspbian I know?
    TIA
    |-<:)



  • From the loading POV, it’s simply not an issue. My machine (RPi3) running openLuup, ZWay and a bridge to Vera runs at about 3% utilisation, on average. @rafale77 will no doubt mention that it is the peak, not the average which matters, but I still stick to the mantra that HA shouldn’t need vast amount of power. Only things like video and perhaps TTS, etc, but they’re generally done with quite different boxes. System management is easier with just one machine (I upgraded to Debian Buster.). Yes, it all works with no internet connection (after initial downloads!). I run two Zwave networks quite happily, albeit with a physical overlap only in the centre of the house.



  • Again, thank you for your insight



  • @IRobot - If I go to the 'Actions' tab of the Z-Way plugin I cannot enter anything.
    zwayactions.JPG

    @rafale77 - It looks like tthe Z-Way API is already enabled.zwayapi.JPG

    I'm still stumped - am I missing something basic here?

    Regards, John.



  • Yup, wrong implementation file. How did you install it?

    You need I_ZWay2.xml.



  • From instructions in the Z-Way Essentials manual dated March 31st, 2020. Section 3.1 "wget -q -O - http://razberry.z-wave.me/install | sudo bash"



  • Or did you mean openLuup: User Guide - version 2018.07.21, Section 1 and Section 2.



  • No, neither, I think. I am talking about the openLuup ZWay plugin device itself. The image you showed of the empty actions tag has the device attributes greyed out in the background. From there I see that you have I_ZWay.xml whereas it should be I_ZWay2.xml. So I am worried about the version of its other files too.

    You can just manually change this attribute to the correct one and restart to see if that fixes things, but the problem may be deeper than that. What version does it say it is?



  • Changed the implementation file..
    9a688f53-f38e-4135-ba4a-e1a2dd21c728-image.png Here is the version...ba048e59-6aea-4282-9c00-12df850c802e-image.png



  • I could not see any Z-Wave devices after changing the implementation file.



  • The version number is very old - totally the wrong thing. Go to the AltUI > More > App Store page, find the ZWay plugin there, and click on the Alt button to download the latest. It should be version 20.5.4b (GitHub.master).



  • Did as you said, now no version number...79c2a084-7096-480f-b78b-826e17fd55f4-image.png

    Attributes...f31a28f9-0d9b-4a7f-b8f5-ac6e76ca82cd-image.png

    I can't help feeling there is something fundamentally wrong here but I have insufficient knowledge to identify what it is. 😕



  • Did you you reload the luup engine after changing the implementation file to I_Zway2.xml?
    Did you check that the file exists in the /etc/cmh-ludl folder?



  • I see this has a new device number, so if device #5 is still there, then delete it.

    I'd like to see the startup log and the openLuup console page Scheduler > Plugins

    It really, really, shouldn't be as much of a pain as this. I don't have a clear picture of quite how things went wrong in the first place.



  • @rafale77 said in Help with Z-Way plugin:

    Did you check that the file exists in the /etc/cmh-ludl folder?

    Actually, it won't be there. Only L_Zway2.lua is a physical file. All its other device files are part of openLuup's virtual storage system.



  • Ohh yes you are right. Sorry about this. I was thinking of the lua file indeed.


Log in to reply